#V3 Testnet #Feedback mint nft

The process of testing the ZK swap V3 went smoothly up until I proceeded to mint an NFT. The ZK swap page loads but the icons dont work and the NFT’s on display under “discover more” dont ever load. I was a not able to connect my wallet on this page as well. The only icon that works on the app page was the “explorer” icon all the other icons did not function for me. I am wondering whether this problem is related to my browser? This is the https ZKSwap - The ZK-Rollups based layer-2 DEX with the AMM model… It looks as if the page is having problems loading the images for the NFT’s.
I am currently using microsoft edge as my browser and have not had any other issues with other pages or platforms. i wish i had some programming experience so that i could give a better deductive reason behind the absence of the page’s functionality. i have given the page over 15 minutes to load the page to no progress.

After spending several hours getting acquainted with ZKSwap V3 I must say that I am very impressed with this rollout!! Trades and swaps worked fine for me, as did transferring funds between L1 and L2 wallets. I tried minting an NFT and, seems no matter how much ETH I have in my L2 wallet, I was unable to. It kept giving me the error message that I had an insufficient balance… Not sure if this is because it’s on testnet and not mainnet, but I thought I’d mention this issue! Apart from that I love the platform, it’s easy to use in most ways and is laid out thoughtfully. A couple things I’d love to see added: I think it would be useful to have a tab at the top of the page that links directly to transaction history, instead of the txn history of being at the bottom of the wallet page. I would also like to have the option to use “dark mode” and not have the background be white all the time though :slight_smile: Thanks for letting me be a part of this! Super excited to see what the future has in store…