Problems signing using Metamask with Ledger


For the last day or two I appear to be unable to successfully sign requests. I’m using Firefox and Metamask with a Ledger device. After pressing “Sign” on Metamask it comes through to the ledger and I can approve the signature, but then nothing seems to happen after that.
Speaking on discord it turns out other users are also experiencing this issue with both Ledger Nano S and X.

Over the weekend I did upgrade my Ledger Nano S to version 2.0.0, but that may be a red-herring.

Hope this is resolved soon so I can activate the PoL mining again.

1 Like

@ZKSwap-James please help the friend solve this problem thanks


I’m facing a similar issue with activating the mining address with the Ledger Nano devices.
Have attempted to clear the cache and tried different browsers, Chrome, Firefox but the issue persists.
I’m only able to unlock my account the ledger device.

It’s now working as expected for me! Thank you to those involved in resolving the issue. <3

1 Like

I can confirm it works now. Cheers to the team!

Hello, I am trying to use my Ledger through Metamask on ZKSwap v3 and signing doesn’t seem to work for me. It just tells me I need to unlock my wallet, I click unlock, sign on my ledger, and then goes back to the unlock button.

How were you able to get around this issue?