#V3 Testnet Feedback# working fine almost

Hi I’m pretty new to crypto, i got my feed in with an airdrop a year ago, now im testing testnets :sweat_smile:

I read some other reviews, and saw all the problems they occured. In my case almost everything worked perfectly, exept the testnet faucet didnt work but i found another one. So the despositing of funds went throu and 5min later i, had my funds deposited.
I minted an NFT. Its super easy, upload the picture, add your website and/or details of the NFT. The UI really looks clean. Then i just pressed mint NFT, super easy super fast mint.

Buying an NFT went throu super smoothly and fast. No problem.

Swaps are working fine too, smooth and fast!

On the NFT tab its not loading the NFTs sometimes.

I saw the mining tab, but its not showing anything. On purpose, or is it a bug?

LP deposit went just fine, no problem.

The whole UI is very intuitive and looks so good. A dark version would be cool! Most websites offer a darkmode and i love it, it rests the eyes.

The explorer is fine too, no problems.

Overall it makes a solid appearance, very good job.

Lets see who wins the L2 race :slight_smile:

Im really looking forward to this project. Hang in there guys!

I wanted to write more but it worked too good for more feedback. If you have any further questions, conract me!

I use windows 8.1 and Brave browser