#V3 Testnet Feedback# problems with ledger

I am trying the new ZKSwap V3 testnet, I have to underline my experience:

On top right of the website the “unlock address” button seems to be disabled (using Chrome browser, last version on Windows O.S.) so it’s not really possible to connect on the landing page, but moving to L2 section it’s possible to try to unlock pressing the button in center of the page. This is an annoying problem that must be fixed before launching the website on final version , please investigate on it.

One important point that I have to underline is that I had some problems using a ledger device connecting by Metamask: when I am trying to connect and unlock wallet, I have to sign by ledger but nothing happens… I am trying several times without succeding at all.

On the other hand, using another account with SW wallet it works properly. Please double check if it’s a common problem.

Using the wallet software it was possible to proceed and correctly load some tokens from my wallet on the site, it is correctly indicated that the transfer takes a few blocks and therefore a few minutes: here it might be useful to insert a popup or something that makes the page flash to notice that the transfer was actually successful because it takes a few minutes

A positive thing the NFT section, I tried with the transferred funds both to buy an NFT from the market and the experience was positive, the market is done well maybe a little slow to load the details (I had to refresh a few times of the page to view it correctly), but then the purchase procedure was excellent. I also tried a mint of an NFT and here too the experience was positive, the procedure is simple, quick, and I did not receive any errors. This section in general worked very well.

have a nice day.

1 Like

Yeah, I have been having similar experience with “Connect Wallet” on the top right. I also tried logging into the wallet and choosing ‘Rinkeby Test Net’ before hand. That doesnot seem make much difference. But it does work after a few tries .

I also try to set ‘Rinkeby Test Ntw’ before but doesn’t work at all…

Not sure my friend , As you said , It would be specific issue with connecting Hardware Wallets. I believe the team is making a note of this

Same issue here it is not possible to unlock a wallet when using metamask + ledger in any configuration (different ports, accounts, rikenby/goerli,… ). Sowtware wallets work as expected.

The ledger is confirmed working properly with other products.

1 Like

Nice and good luck for V3…


hi i tried using this new ZKSwap V3 testnet with a little experience i have in minting NFT. at first it was confusing for me since im not familiar with rinkeyby faucet and i try claiming it unfortunately never get ant rinkeyby eth so i did a try and deposit test net that i get from zkswap and try to deposit it then swap it in L2 to eth surprisingly im able to mint my first NFT its fast and easy to use for those people like me with a lttle experience when come to minting NFT in zkswap it more very staright forward that even a 6 grader will be able to use them and sell thier nft.

for swaping token im a little confuse since my testnet token is already in L2 but when i try to swap it show no balance in my L2 wallet then from there i know that i need to deposit it and able to buy and sell my nft over all it was a smooth transaction easy to use and fast approval i think i really will recommend using zkswap its easy to use fast approval no failed in my transaction at all fo my feedback for zkswap is all positive, i wish this project will be known in the market worldwide. thank you for the oppurtunity and im able to try this amazing project.

1 Like

You can just Swap from One token to another