#V3 testnet #feefback transaction V3.0 my feedback

ZKSWAP V3.0 Test

I have just tried out zKSwap v3.0

Before going v3.0 I tried to use v2.0 but I have experienced some issues. I had some problem connecting and unlocking wallets. It disconnects and wallet needed to connect and unlock again when. But with V3 it seems that this issue has been solved. It easily connects and unlock wallet w/o any problem.

This was for the part connecting and unlocking wallets.

Let’s continue with second one L2 Wallet > Deposit

Depositing was also really nice and easy and did not have any issue for that. Easily deposited some Ether from the Goerly network using metamask. Did not have a problem using this tool too. It was really nice comparet to V2.0. By the way I did not know about zkswap when v2.0 was in test. I just came for v3.0 and used v2.0 too.

Then swapped some ether for ZKS. Then swapped some of my ZKS for USDT and had no problem with that.

Then NFT Section

I have used a nice picture from my hometown in order to mint my first NFT ever. I did not have minted any nft on any platform. This was really first one and it was easy using menu.

I have filled the informations and clicked the Mint NFT button I recieved Unknown Error. I thought it was due to size of my image. It was not squareshaped so I have changed to another image but the problem persists. I changed the image with a logo and got the same error…

In order to solve this I needed to disconnect wallet and connect again. After that it worked in a nice and clean way.

When I try to NFT Mall in order to buy one I just picked an NFT for sale with some USDT but I have ETH and ZKS and as expected I had “In sufficient fund” error. it can be helpful for user to have a button to swap ETH for USD or to have a link to redirect to SWAP Page.
This is basiaclly my experiment with zkswap v3.0.

It was my first time to use this service and overall I feel that I can use it after test is comleted.


1 Like