#V3 Testnet Feedback#

While testing ZKSwap app i encountered following minor problem:

  1. Visit https://vsan.zks.app and unlock the wallet.
  2. Click “NFT” → “NFT Mall”
  3. Choose any NFT and click “Buy”
  4. Accept terms and click “Confirm”.
  • at that point nothing happens, neither zks app popup and no transaction in metamask if i manually open it
  1. Click “Confirm” again.
  • this time zks app popup appears (“Waiting for confirmation…”), but metamask doesnt, however if i manually open metamask, its asking me to “Sign” the transaction.
  1. Everything is working normal at that point.

I was able to reproduce that scenario multiple times with various nft’s.
Used browser: Firefox

My wallet: 0x34b79E1B53D240F7706537Ce0C8988C0247b5129

Hello. Interesting product. For now it is the best place there I can fast and easy make my own NFTs.
But I had some problems here.

  1. I created my NFT twice, because then I created first time, the platform write that succeed, but I didnt find it in my products. Then I made it second time and it was perfect.
  2. I tried to put my NFT to sell. And here again I do it from the second time. Hm. It was very strange for me. Second move and second move from second time.
  3. I tried to buy one NFT. Transaction wrote succeed, but I didnt found NFT in my collection. The I saw the same NFT (maybe it was NFT that I wanted to buy) on NFT mall and the prise was 10 time bigger. So I tried to buy another one and I did it.
    So for now I have one minted and one bought NFTs.
    For me very comfortable that I can choose with witch crypto currency I ll pay for NFT.
    So go head and youll be the best NFT platform.

P. S. Forgot my wallet :slight_smile: : 0x2E5F97Ce8b95Ffb5B007DA1dD8fE0399679a6F23