#V3 Testnet Feedback# New

My initial experience was that the weblink took forever to be ready. Several refreshes enabled me to then connect my wallet (an option which previously had not worked prior to the refreshes).

Adding ETH to the wallet took around 30 minutes, I do not know whether this was down to traffic on the ETH blockchain or an issue with ZKS but something you could maybe review.

Creating my account was very smooth.

Adding an NFT was also very smooth.

Minting, this took several attempts as I kept getting a message advising me of Network Error. There was no means to diagnose this error and no further description to the error.

Basically, re-tried 30 mins or so later and successfully minted my NFT.

I’ve not tried any other functions yet, will write up the experience when I get opportunity to trial them and time to write it up.

All looking positive if you can iron out some of these kinks causing delays.

Menu options are clear. Display is clean (though a dark mode would be a good option to have).
Straightforward to navigate for what I have tried so far.